
 MODULUL 4.1

 BAZELE UTILIZĂRII APLICAŢIILOR DE CALCUL TABELAR; 
APLICAŢIA CALC DIN OPENOFFICE.
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4. CALCUL TABELAR CU OPENOFFICE.ORG CALC 

4.1. Operaţii elementare şi concepte de bază ale aplicaţiei Calc din OpenOffice.org 

4.1.1. Generalităţi; Proiectarea şi crearea documentelor 

Calc este cel de-al doilea program pe scara popularităţii din suita de programe Open Office.org. 
Acesta face parte din gama aplicaţiilor de calcul tabelar, permiţând efectuarea prelucrărilor de date 
organizate sub formă de tabele în foi de calcul electronice.  Calc  oferă facilităţi de calcul, utilizând 
formule  simple  sau  complexe,  schimburi  de  informaţii  între  aplicaţii  de  acelaşi  tip  sau  de  tipuri 
diferite, reprezentări grafice, etc.. 

Aplicaţiile  de calcul  tabelar,  printre  care şi  OpenOffice.org Calc,  servesc la  organizarea şi 
procesarea  informaţiilor,  în  special  a  acelora  de  tip  numeric.  Un  document  Calc  poate  avea  o 
multitudine de utilităţi, de la simple calcule aritmetice până la evidenţe de tip contabil şi financiar. 

Printre avantajele utilizării unei astfel de aplicaţii se pot menţiona: 
 Raportările şi situaţiile de tip economic dintr-o organizaţie se elaborează, de regulă, periodic 

(zilnic, săptămânal, lunar, trimestrial, anual), pe aceeaşi structură, doar că de fiecare dată cu 
alte valori.  Din acest motiv,  este suficient să se definească o singură dată structura foii de 
calcul (antetele de rând şi de coloană, formulele de calcul, etc.), urmând ca apoi raportările să 
fie completate periodic cu datele curente; 

 Datele utilizate în foile de calcul pot fi reprezentate grafic, astfel încât să poată fi prezentate 
într-o formă sugestivă şi sintetică; 

 Un document de tip Calc poate servi la crearea unor tabele complexe şi de mari dimensiuni. 

Etapele pentru proiectarea şi crearea unui document nou de calcul tabelar sunt: 
1.  Definirea obiectivelor  documentului  şi  ale  foilor  de calcul  (situaţia  stocurilor,  un stat  de plată, 
evidenţa veniturilor şi a cheltuielilor, etc.); 

2.  Definirea cerinţelor foilor de calcul - stabilirea datelor de intrare, a calculelor ce se vor efectua 
asupra acestora şi a formei în care vor fi furnizate rezultatele; 

3.  Construirea structurii foilor de calcul – anteturile coloanelor şi ale liniilor, stabilirea celulelor cu 
date de intrare, a celor cu expresii de calcul, în conformitate cu cerinţele foii de calcul; această etapă 
implică şi stocarea documentului pe un suport electronic; 

4.  Exploatarea  foilor  de  calcul  -  introducerea  datelor  şi  prelucrarea  lor  prin  calculare,  formatare, 
reprezentare grafică, astfel încât rezultatele să fie furnizate în forma dorită. 

Crearea şi  procesarea unui document OpenOffice.org Calc  presupune cunoaşterea celor 
mai uzuale caracteristici şi operaţii specifice aplicaţiilor de calcul tabelar (introducerea şi modificarea 
informaţiilor,  formatarea  numerică,  crearea  expresiilor  de  calcul,  utilizarea  diverselor  categorii  de 
funcţii, operarea cu tabele tip baze de date, reprezentarea grafică a datelor, etc.). 

4.1.2. Deschiderea aplicaţiei 

Lansarea  în  execuţie  se  realizează  astfel:  Start  →  All  Programs  →  OpenOffice.org  → 
OpenOffice.org  Calc  După  lansarea  în  execuţie  a  programului,  pe  ecran  apare  fereastra  Calc, 
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prezentată în figura următoare. 

Lucrarea creată în Calc se numeşte Document. Fiecare document conţine un anumit număr de foi de 
calcul numite Sheet. 

Interfaţa Calc conţine elemente cunoscute din alte aplicaţii OpenOffice.org (bara de titlu, bara 
de meniu, bare de instrumente, bara de stare, şi barele de defilare), precum şi elemente specifice (zona 
de lucru, caseta Name Box, bara Input line, bara de formule). 

Zona de lucru este constituită din foaia de calcul curentă. Aceasta este împărţită în coloane şi 
linii (rânduri). Coloanele sunt numite în ordine alfabetică de la A la IV, iar rândurile, numeric, de la 1  
la 65536. Intersecţia dintre un rând şi o coloană se numeşte cell (celulă). Fiecare celulă are o adresă 
formată din literele coloanei urmate de numărul rândului, la intersecţia cărora se află. 

Casetă Name Box,  situată pe bara de formule,  sub barele de instrumente în partea stângă, 
afişează adresa celulei  curente şi  permite  deplasarea rapidă  la  o  anumită  celulă  a  cărei  adresă se 
tastează în casetă. 

Bara Input line  situată pe bara de formule, permite afişarea şi editarea conţinutului celulei 
curente. 

Afişarea sau ascunderea barei Formula Bar şi a casetei Name Box se realizează prin bifarea sau 
debifarea opţiunii Formula Bar din meniul View.

În  stânga  barei  de  defilare  orizontală  se  situează  lista  cu  indicatoarele  foilor  de  calcul  şi 
butoanele pentru deplasarea între acestea: 
- vizualizarea începutului listei; 
- ◄   deplasarea listei spre început cu o foaie;
- ►   deplasarea listei spre sfârşit cu o foaie; 
- vizualizarea sfârşitului listei. 

La un moment dat doar una din foile de calcul ale documentului este curentă şi aceasta se 
selectează cu clic pe numele ei din lista cu indicatoarele de foi. 

Fiecare foaie electronică de calcul are un nume implicit Sheet1. O celulă dintr-o foaie de calcul 
va  fi  referită  în  formulele  de calcul  prin  nume foaie.referinţă  celulă,  (exemplu:  Sheet1.A1)  dacă 
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referirea se realizează în altă foaie de calcul decât cea curentă. Dacă referirea se realizează în foaia de 
calcul curentă celula va fi referită doar prin referinţa sa (exemplu: A1). 

4.1.3. Crearea unui document nou 

Salvarea fişierelor Calc se realizează din File → Save. 
În  cadrul  acestei  operaţii  se  stabilesc  următoarele  opţiuni: 
numele  fişierului,  locaţia  (folderul  de  stocare)  şi  tipul 
fişierului. Documentele create cu  Calc  sunt implicit de tipul 
Open Document Spreadsheet cu extensia .ods. 
În  caseta  de  dialog  pentru  salvare  în  caseta  File  Name  se 
introduce  numele  documentului  şi  la  rubrica  Save  in,  se 
stabileşte  folderul  în  care  se  salvează  documentul.  Implicit 
fişierul se salvează cu extensia ods. 
Dacă se doreşte salvarea într-un alt format, din lista  Save as  
type, se selectează formatul dorit. Documentul poate fi protejat 
printr-o  parolă.  În  acest  caz  se  bifează  caseta  Save  with 
password, apoi se apasă butonul Save. Dacă s-a bifat caseta 
Save with password, în urma apăsării butonului Save, apare o 
casetă în care trebuie introdusă şi confirmată parola. 

Calc permite stabilirea unor opţiuni suplimentare pentru salvare din Tools → Options. 
 Realizarea unei copii de rezervă la fiecare salvare. Se bifează opţiunea Always create backup 

copy din caseta de dialog de mai jos. 

 Salvarea pentru recuperarea automată. Se bifează opţiunea  Save AutoRecovery information  
every şi se stabileşte perioada de timp după care va face automat salvarea. 

Schimbarea  unităţilor  de  măsură  se  realizează  din  Tools  → Options  → OpelOffice.org  Calc  → 
General → caseta Measurement Unit 
Schimbarea opţiunilor de salvare ale fişierului curent se realizează din  File → Save As. Închiderea 
documentului curent se realizează din meniul File → Close. Părăsirea aplicaţiei presupune închiderea 
automată a tuturor documentelor deschise şi se realizează prin File → Exit. 

4.1.4. Funcţia ”Ajutor” (Help) 

Help reprezintă un ghid interactiv de ajutor. Lansarea în execuţie a ghidului se realizează din 
meniul Help → OpenOffice.org Help 

Tabul  Index afişează o listă cu toate comenzile, dispuse alfabetic. La rubrica Search item se 
scrie numele comenzii, apoi se apasă butonul display. În ecranul din dreapta se vor afişa informaţii cu 
privire la comanda căutată. În exemplul s-au căutat  informaţii  cu privire la salvarea documentelor 
(saving; documents). 

Tabul  Find permite căutarea după cuvinte cheie. Se scrie cuvântul la rubrica Search, apoi se 
apasă butonul Find. Se va afişa o listă cu apariţiile respectivului subiect. Se selectează o opţiune din 
listă, apoi se face clic pe Display. În ecranul din dreapta se va afişa secvenţa respectivă de instrucţiuni. 
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In exemplu s-a căutat cuvântul save. 
Tabul Contens afişează structurat o ierarhie a facilităţilor produsului Calc. Din lista afişată se 

selectează pe rând, cu dublu clic operaţia pentru care avem nevoie de documentaţie. În exemplu s-a 
afişat modul de scriere al textului pe mai multe rânduri. 

Ce aţi învăţat în acest capitol? 
 Noţiuni generale despre OpenOffice. org Calc. 

 Cum se deschide aplicaţia OpenOffice. org Calc. 

 Cum se salvează un document creat cu OpenOffice. org Calc. 

 Cum se închide aplicaţia OpenOffice. org Calc. 

 Care este rolul şi modul de utilizare al funcţiei “Ajutor” (Help). 
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4.2. Gestionarea datelor din foile de calcul 

4.2.1. Selectarea celulelor 

Pentru multe acţiuni ce se efectuează în Calc trebuie să se selecteze una sau mai multe celule. 
Există mai multe modalităţi de selectare a celulelor: 

 Selectarea unei celule – alegerea celulei ca celulă activă prin clic în celulă; 

 Selectarea unui bloc de celule  (zona compactă de celule adiacente),  se poate  face în două 
moduri: 

- clic pe una din celulele din colţul zonei → glisarea mausului până în colţul diagonal opus; 
- clic pe una din celulele din colţul zonei → cu tasta Shift apăsată clic pe colţul diagonal opus. 

Adresa unui bloc de celule (zonă compactă de celule adiacente) se exprimă ca adresa primei 
celule din grup (colţul stânga sus), urmata de semnul „:” şi apoi de adresa ultimei celule a blocului 
(colţul dreapta jos). 

Exemplu: 

 Selectarea unor celule/blocuri neadiacente – se selectează prima celulă/primul bloc → cu tasta 
Ctrl apăsată se selectează pe rând celelalte celule/blocuri; 

 Selectarea  tuturor  celulelor  din  foaia  curentă  –  clic  pe  butonul  Selectare  totală  (aflat  la 
intersecţia antetelor de rând şi de coloană) sau tastarea combinaţiei de taste Ctrl + A; 

 Selectarea celulelor unui rând – clic pe numărul rândului; 

 Selectarea celulelor unor rânduri, dacă rândurile: 
- sunt adiacente - clic pe numărul primului rând şi se glisează până pe numărul ultimului rând dorit; 
- nu sunt adiacente - clic pe numărul primului rând şi, ţinând tasta  Ctrl  apăsată, clic pe numerele 
celorlalte rânduri sau se glisează peste rândurile respective; 

 Selectarea celulelor unei coloane - clic pe numele coloanei; 

 Selectarea celulelor unor coloane, dacă coloanele: 
- sunt adiacente - clic pe numele primei coloane şi se glisează până la numele ultimei coloane dorite; 
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- nu sunt adiacente - clic pe numele unei coloane şi, ţinând tasta Ctrl apăsată, clic pe numele celorlalte 
coloane sau se glisează peste coloanele respective. 

Există 3 moduri de selectare, între care se poate comuta cu dublu clic pe butonul corespunzător 
din bara de stare a aplicaţiei. 

 Modul standard (STD) reprezintă modul de selectare implicit. 

 Modul extins (EXT) permite extinderea selecţiei de la celula curentă până la celula în care se face 
clic, echivalentul selectării unui bloc de celule cu tasta Shift 

 Modul adăugat (ADD) permite selectarea blocurilor de celule nealăturate, echivalentul selectării 
unui bloc de celule cu tasta Ctrl. 

4.2.2. Introducerea şi modificarea informaţiilor 

 Introducerea informaţiilor se realizează astfel: se selectează celula cu clic pe ea şi se tastează 
conţinutul. Acesta apare atât în celulă cât şi în bara de formule. Terminarea introducerii se face 
prin confirmarea informaţiilor introduse: 

- Tasta Enter – celulă activă devine celula de mai jos; 

- Clic pe butonul   de pe bara cu formule – celulă activă rămâne tot celula curentă; 

- Tasta Tab – celulă activă devine celula din dreapta. 

sau prin renunţarea la introducerea acestor informaţii: 
- Tasta Esc – celulă activă rămâne tot celula curentă; 

- Clic pe butonul   de pe bara cu formule – celulă activă rămâne tot celula curentă. 

 Modificarea conţinutului unei celule se realizează prin două metode: 

- Selectând celula cu clic în interior, clic în bara de formule, apoi se operează modificarea, sau 

- Dublu clic în celulă, apoi se operează modificarea. 
Terminarea modificării se face la fel ca terminarea introducerii informaţiilor. 

 Informaţiile în Calc sunt clasificate în două tipuri: 
-Informaţii  numerice  care  cuprind  numere  întregi,  numere  zecimale,  numere  procentuale,  numere 
însoţite de simboluri monetare, date calendaristice, momente de timp; implicit aceste informaţii se 
aliniază la dreapta celulei. 

-Informaţii text care conţin litere, numere şi alte simboluri; implicit aceste informaţii se aliniază la 
stânga celulei. 

 Facilităţi de introducere a datelor: 
- Introducere automată - AutoInput – completează textul în curs de editare din celula curentă cu un 
text  existent  mai  sus  pe  aceeaşi  coloană  şi  care  începe  cu  literele  deja  tastate.  Se  poate  accepta 
completarea automată cu  Enter, sau se poate continua editarea în cazul în care textul diferă de cel 
propus. Opţiunea  AutoInput  este case-sensitive (se ţine cont de starea de majusculă sau minusculă a 
literei). Dacă, de exemplu, este scris în celulă "Total", nu se va putea introduce "total" în altă celulă din 
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aceeaşi coloană, fără să se fi dezactivat mai întâi AutoInput. Activarea sau dezactivarea AutoImput se 
realizează astfel: Tools → Cells Contens → AutoInput 

- Umplere automată (AutoFill) – reprezintă o caracteristică pentru automatizarea introducerii datelor. 
Aceste date constituie liste sau serii de informaţii. 

Listele -  reprezintă o înşiruire de informaţii de tip text. Pentru a utiliza o listă ea trebuie să existe.  
Există liste predefinite, dar pot fi şi liste create de utilizator. Listele pot fi vizualizate în meniul Tools  
→ Options → OpenOffice.org Calc → Sort List:

Crearea unei liste de către utilizator se poate face prin două metode: 
-  Din caseta  de dialog de mai  sus  se  face clic  pe butonul  New,  apoi  în  zona  Entries  se tastează 
elementele listei separate prin Enter, apoi Add → OK. 

-  Dacă elementele listei există deja într-un bloc în foaia de calcul (pe un rând sau pe o coloană) de 
celule: se selectează acest bloc, apoi din caseta de mai sus se face clic pe butonul Copy → OK. 

Ştergerea unei liste create de utilizator: 
Din caseta de mai sus se selectează lista ce urmează a fi ştearsă din zona Lists, apoi se face clic 

pe butonul Delete. Apare o casetă în care se cere confirmarea ştergerii. Pentru confirmare se apasă Yes. 

Completarea automată a celulelor cu informaţii pe baza unei liste: Se tastează într-o celulă 
un  element  din  listă  → clic  pe  colţul  dreapta  jos  al  celulei,  pe  reperul  de  completare  Umplere 
automată (AutoFill) şi se glisează mausul peste celulele ce se doresc umplute. 

Seriile -  o serie de date poate reprezenta un şir de numere aflate în progresie aritmetică sau 
geometrică, date calendaristice ordonate după diverse criterii sau serii numerice cu text asociat. 

Completarea automată a celulelor cu serii numerice Se completează în două celule alăturate 
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doi termeni consecutivi ai  unei serii  de numere în progresie aritmetică → se selectează cele două 
celule (vezi  selectarea celulelor)  → clic pe reperul  AutoFill  al blocului cu celulele selectate  şi  se 
glisează mausul peste celulele ce se doresc umplute. 

Completarea automată a celulelor cu serie text Se tastează într-o celulă un element din serie 
→clic pe reperul AutoFill al celulei şi se glisează mausul peste celulele ce se doresc umplute. 

Exemplu: Umpleri automate pe bază de listă, serie numerică, serie text: 

LISTĂ SERIE NUMERICĂ SERIE TEXT

LUNI 10 Capitolul 1

MARTI 12 Capitolul 2

MIERCURI 14 Capitolul 3

JOI 16 Capitolul 4

VINERI 18 Capitolul 5

SÂMBĂTĂ 20 Capitolul 6

DUMINICĂ 22 Capitolul 7

4.2.3. Inserarea rândurilor / coloanelor / celulelor / foilor de calcul 

Pe parcursul lucrului în foaia de calcul se poate opta ca între anumite date să se mai introducă 
altele fără a le pierde pe cele deja introduse. În acest caz se pot introduce celule, rânduri, coloane sau  
foi electronice de calcul goale care ulterior se vor umple cu datele dorite. 

 Inserare de rânduri 

Se selectează câte o celulă din fiecare rând ce va fi sub noile rânduri goale, apoi Insert → Rows; 

 Inserare de coloane 

Se selectează câte o celulă din fiecare coloană ce va fi în dreapta noilor coloane goale, apoi Insert → 
Columns; 

 Inserare de celule 

Se selectează celulele ce se află pe poziţia unde se doresc celulele goale, noi, apoi  Insert  → Cells.  
Apare o casetă de dialog din care se alege acţiunea dorită a se efectua cu celulele selectate după 
introducerea celor noi, sau se poate opta pentru introducerea unor rânduri sau coloane noi întregi în 
zona selectată; 

 Inserarea foilor electronice de calcul 
Se selectează o foaie de calcul, apoi Insert → Sheet. Apare caseta de dialog Insert Sheet: 
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-  Din zona Position se alege unde se inserează noua foaie de calcul.  Before current sheet  inserează 
înaintea sheet-ului selectat şi After current sheet inserează după sheet-ul selectat. 

- Din zona Sheet se alege inserarea unui singur sheet (New sheet), sau inserarea mai multor sheet-uri. 
În acest caz la rubrica No. of sheets se introduce numărul de sheet-uri ce urmează a fi inserat. 

- Opţiunea From file permite inserarea sheet-urilor din alte documente. Selectarea documentului sursă 
se face prin apăsarea pe butonul Browse. Este posibilă menţinerea unei legături permanente cu sheet-
ul din fişierul sursă, prin bifarea opţiunii Link. 

4.2.4. Ştergerea celulelor / rândurilor / coloanelor / foilor electronice de calcul 
Datele din foaia electronică de calcul se pot şterge astfel: 

 Ştergerea conţinutului celulelor 

Se selectează celulele → se apasă tasta Delete; Dintr-un bloc de valori diferite ca tip, se pot şterge doar 
valorile de un anumit tip, prin selectarea tipului în caseta de mai sus, astfel: doar şiruri de caractere 
(Strings),  numere  (Numbers),  date  calendaristice  sau  momente  de  timp  (Date  &  time),  formule 
(Formulas),  note (Notes),  formatări  (Formats).  Pentru ştergerea întregului bloc selectat  inclusiv a 
formatărilor se alege opţiunea Delete all. Ştergerea conţinutului unui bloc fără ştergerea formatărilor 
se realizează prin apăsarea tastei Backspace. 

 Eliminarea celulelor, rândurilor, coloanelor se realizează astfel: 

Se selectează celulele de şters sau aflate pe rândurile/coloanele ce urmează a fi şterse, apoi  Edit → 
Delete Cells 

 Ştergerea foilor de calcul (Ruperea) 

Se selectează indicatorii Edit → Sheet → Delete. 

4.2.5. Redimensionarea rândurilor / coloanelor 

În cazul în care dimensiunea coloanelor ce conţin valori numerice este prea mică, în celulele 
respective se afişează eroarea ####. Redimensionarea rândurilor/coloanelor se face indiferent de tipul 
informaţiilor conţinute, astfel: 
-  Manual  – se poziţionează mausul pe chenarul din dreapta numelui coloanei sau de sub numărul 
rândului şi se glisează până la dimensiunea dorită. 

- Automat – se selectează celule din rândul/rândurile sau coloana/coloanele respective → Format şi se 
alege una dintre variantele: 

1. Pentru rând:  Row → Height → Optimal Height → adaptează înălţimea rândului la cea mai 
înaltă informaţie conţinută.; 

2. Pentru coloană :  Columns → Width → Optimal Width → adaptează lăţimea coloanei la cea 
mai lată informaţie conţinută. 
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4.2.6. Redenumirea foii de calcul 

1. Clic pe numele foii al cărei nume trebuie modificat. 

2.  Se deschide meniul contextual şi se alege comanda  Rename. Apare o casetă de dialog în care se 
introduce numele nou al foii, apoi se apasă OK. 

O altă modalitate : se menţine tasta Alt apăsată, se face clic pe numele foii, apoi se introduce numele 
nou şi se apasă tasta Enter.
 
Ce aţi învăţat în acest capitol? 

 Cum se realizează selectarea celulelor, 

 Cum se introduc şi modifică informaţiile, 

 Cum se lucrează cu serii şi liste de date, 

 Cum se inserează şi se şterg celulele, rândurile, coloanele, foile de calcul, 

 Cum se redimensionează rândurile şi coloanele, 

 Cum se redenumesc foile de calcul. 
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4.3. Formatarea 

Pentru ca datele dintr-o foaie de calcul să poată fi interpretate mai uşor este indicat ca după 
introducerea lor să fie formatate, adică să li se schimbe aspectul (culoare, dimensiune, etc.). 

4.3.1. Formatarea celulelor 

Formatarea se realizează astfel: 
1. Se selectează elementele (celule, rânduri, coloane) în care există date al căror aspect se va schimba. 

2.  Se alege din meniul  Format  comanda  Cells  – pentru formatarea celulelor;  va apărea caseta de 
dialog Format Cells. Aceasta are mai multe taburi: 

Tabul  Numbers  – permite alegerea modului de reprezentare a diferitelor tipuri  de date din celule, 
conform categoriei alese din lista Category. Dintre categoriile cel mai des utilizate amintim: 

 All – anulează formatarea existentă pentru valori numerice. 

 Number – permite: 
- Stabilirea numărului de zecimale (Decimal places); 

- Afişarea numerelor utilizând separator mii (Thousands separator); 

- Afişarea numerelor negative în roşu (Negative Numbers red). 

 Percentage – permite: 
- Transformarea valorii numerice existentă în celulă într-o valoare procentuală prin înmulţirea valorii 
iniţiale cu 100 şi adăugarea simbolului „%”; 

- Stabilirea numărului de zecimale - Decimal places. 
 Currency – afişează valorile numerice însoţite de simbolul monetar şi permite: 

- Alegerea limbii pentru simbolul monetar din lista  Language. Limba implicită este cea aleasă din 
Control Panel→Regional and Language Options 
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- Stabilirea numărului de zecimale (Decimal places); 

- Afişarea numerelor utilizând separator mii (Thousands separator); 

- Afişarea numerelor negative în roşu (Negative Numbers red). 

 Date – permite: 
- Alegerea limbii pentru data calendaristică din lista Language. 

- Selectarea diferitelor formate pentru data calendaristică din lista Format. 
 Time – permite: 

- Alegerea limbii pentru momentul de timp din lista Language. 

- Selectarea diferitelor formate pentru momentul de timp din lista Format. 

Tabul Alignment – permite alinierea conţinutului celulei (pe orizontală şi verticală), orientarea, 
încadrarea textului în celulă. 
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 Text alignment permite alinierea textului pe orizontală (Horizontal) şi pe verticală (Vertical) în 
cadrul celulei. 

 Text Orientation permite înclinarea textului cu un unghi, sau scrierea pe verticală. 

 Proprietatea Wrap text automatically permite împărţirea automată a textului din celulă pe mai 
multe rânduri în funcţie de lăţimea celulei. 

 Proprietatea Shrink to fit cell size permite redimensionarea textului din celulă astfel încât să se 
încadreze pe un singur rând în lăţimea coloanei. 

Tabul Font (Font) – permite precizarea caracteristicilor fonturilor după cum urmează: 

- Lista Font – permite alegerea unui corp de literă. 
- Lista Tipeface – permite alegerea stilului fontului: 
- Regular – Obişnuit – valoare implicită; 

- Italic – Cursiv – înclinat; 

- Bold – Aldin – îngroşat; 

- Bold Italic – Aldin Cursiv – îngroşat şi înclinat. 
 Lista Size – permite schimbarea dimensiunii fontului. 

Tabul Font Effects – permite precizarea caracteristicilor fonturilor după cum urmează: 
- Lista Underlining – permite alegerea unui stil de subliniere. 

- Lista Font Color – permite modificarea culorii textului. 

- Stikethrough – taie textul selectat cu o linie. 

Tabul Borders – permite alegerea stilului, culorii şi poziţiei chenarelor celulelor selectate. 
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- Lista Style – permite alegerea unui stil de linie. 

- Lista Color – permite alegerea culorii liniei. 

- Zona Line arrangement – conţine opţiunile pentru chenar astfel: 
- Set No Borders – elimină chenarele existente; 

- Set Outer Border Only – adaugă chenar în exteriorul blocului de celule selectat; 

-  Set  Outer Border  Only And Horizontal  Lines  – adaugă chenar  în  exteriorul  blocului  de celule 
selectat şi liniuţe orizontale între celule. 

- Set Outer Border Only And All Inner Lines – adaugă chenar în exteriorul şi interiorul blocului de 
celule selectat 

- Set Outer Border Only Whithout Changing Inner Lines – adaugă chenar în exteriorul blocului de 
celule selectat, fără să modifice chenarul interior existent. 

Tabul Background – permite alegerea culorii de fundal pentru celulele selectate. 

4.3.2. Îmbinarea celulelor 

Prin operaţia de îmbinare a celulelor se înţelege unirea a două sau mai multe celule alăturate 
selectate şi transformarea lor într-o singură celulă. Celula astfel obţinută va avea adresa primei celule 
din grupul selectat. Operaţia se realizează astfel: Se selectează grupul de celule ce trebuie unit Format 
→ Merge Cells  Sau clic pe bara de formatare pe butonul  Merge Cells  Pentru anularea operaţiei se 
procedează exact la fel ca şi la operaţia de unire a celulelor. 

4.3.3. Crearea şi utilizarea stilurilor 

Stilurile reprezintă un grup de formatări ce pot fi atribuite celulelor sau obiectelor. Stilurile pot 
fi create, actualizate, sau şterse. 
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4.3.4. Ascunderea rândurilor, coloanelor, foilor de calcul 

Un rând, coloană, sau foaie de calcul ascunsă, nu mai apare nici pe ecran, dar nici pe hârtie, 
dacă se tipăreşte 

• Ascunderea rândurilor, coloanele se realizează astfel: 

1. Se selectează rândul sau coloana respectivă 

2. Format → Rows / Columns → Hide 

• Afişarea rândurilor, coloanele ascunse: 

1. Se selectează rândurile sau coloanele învecinate celei ascunse, apoi 

2. Format → Rows / Columns → Show 

Dacă a fost ascunse prima coloană, sau primul rând, pentru afişare se selectează întreaga foaie 
de calcul, apoi Format → Rows / Columns → Show 

• Ascunderea foii de calcul se realizează din Format → Sheet → Hide. 

• Afişarea foii de calcul se realizează din Format → Sheet → se selectează din listă numele foii 
de afişat → Show. 

4.3.5. Protejarea datelor 

Protejarea  presupune  prevenirea  editării  (modificării,  ştergerii)  unei  foi  de  calcul,  a  unui 
document sau doar a anumitor celule dintr-o foaie de calcul. În cazul în care se doreşte protejarea 
anumitor celule dintr-o foaie de calcul împotriva modificărilor neautorizate, acele celule vor trebui 
întâi formatate cu opţiunea Protected, şi abia apoi se va putea stabili protecţia foii de calcul, eventual 
cu parolă. 
Protejarea celulelor  Primul pas este acela de a formata ca „Protected” acele celulele din foaia de 
calcul care vor fi protejate, şi a elimina această formatare pentru celelalte. Pentru aceasta: 

1. Se selectează întreaga foaie de calcul 
(Ctrl + A) 
2. Format → Cells → tabul Protection 
3. Se debifează opţiunea Protected,  
pentru a deproteja întregul conţinut al 
foii de calcul → OK 
4. Se selectează în foaia de calcul 
celulele ce vor fi protejate împotriva 
modificărilor 
5. Format → Cells → tabul Protection 
6. Se bifează opţiunea Protected 

Observaţie: Protejarea 
celulelor  nu  are  nici  un  efect  atâta 
timp  cât  foaia  de  calcul  nu  este 
protejată,  de  aceea  următoarea  etapă 
va fi aceea de protejare a foii. 
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Tabul Protection al casetei de dialog Format Cells permite, de asemenea: 
• Ascunderea conţinutului celulelor selectate, cu opţiunea Hide All 

• Ascunderea  formulelor  din  celulele  selectate  (formulele  nu  vor  mai  fi  afişate  în  bara  de 
formule  la  selectarea  celulei  şi  nici  în  celulă  la  dublu  clic  pe  aceasta),  cu  opţiunea  Hide 
Formula. 

Aceste opţiuni de protecţie au efect doar atâta timp cât foaia de calcul este protejată. 
Protejarea  unei  foi  de  calcul  Pentru  a  activa  protecţia  foii  de  calcul:  Tools  →  Protect  

Document → Sheet. În caseta de dialog Protect Sheet se poate, opţional, să se aleagă protejarea cu o 
parolă, care se introduce în caseta Password şi se confirmă în caseta Confirm. 

După stabilirea protecţiei,  celulele protejate nu mai pot fi editate, formatate, şterse, mutate. 
Pentru a dezactiva protecţia aplicată foii de calcul: Tools → Protect Document→ Sheet şi, dacă este 
solicitată, se introduce parola. 

Protejarea documentului  Protejarea documentului  presupune protejarea structurii  acestuia. 
Pentru protejarea registrului de calcul:  Tools → Protect Document → Document Opţional, se poate 
stabili şi o parolă. Elementele de structură care pot fi protejate într-un document Calc: 

• Vizualizarea foilor de calcul ascunse 

• Redenumirea foilor de calcul 

• Mutarea, ştergerea, ascunderea foilor de calcul 

• Inserarea de noi foi de calcul 

• Mutarea sau copierea foilor de calcul într-un alt registru 

4.3.6. Formatarea condiţională 

Reprezintă aplicarea unor caracteristici de formatare doar acelor celule dintr-o selecţie care se 
supun unei sau mai multor condiţii  (restricţii)  precizate de utilizator.  Pot fi  impuse maximum trei 
condiţii. Se va proceda în felul următor: 
1. Se selectează celulele cărora li se aplică formatarea condiţională 

2. Format → Conditional Formatting 

3. Apare caseta de dialog Conditional Formatting
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4. În rubrica Condition 1 se precizează prima condiţie: 
- Cell Value Is (Valoarea celulei este) 

- Operatorul relativ se introduce în caseta următoare, prin selectarea uneia din variantele predefinite 
din lista derulantă 

- In caseta a treia, şi eventual a patra, se introduc valori (constante, adrese de celule, formule, etc.) 
pentru comparaţie 

5.  Din lista  Cell Style  se selectează stilul ce va fi aplicat celulelor ce respectă condiţia stabilită. Se 
poate opta pentru unul din stilurile predefinite sau pentru stiluri create de utilizator în prealabil. 

6.  Pot fi  create  până la  trei  astfel  de condiţii  completând rubricile aferente pentru  Condition 2  şi 
Condition 

7. Se confirmă cu OK şi formatarea condiţională va fi aplicată. 
Eliminarea formatării condiţionale  se face selectând celulele şi debifând condiţia/condiţiile create 
anterior. 

Ce aţi învăţat în acest capitol? 
• Cum se formatează celulele şi informaţiile conţinute de acestea. 

• Cum se realizează operaţia de îmbinare a celulelor. 

• Cum se creează şi utilizează stilurile. 

• Cum se pot ascunde rânduri, coloane şi foi de calcul. 

• Care se protejează celulele foilor de calcul şi documentele. 

• Cum se poate realiza formatarea celulelor în funcţie de una sau mai multe condiţii. 
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