
 MODULUL 4.3

 BAZELE UTILIZĂRII APLICAŢIILOR DE CALCUL TABELAR; 
APLICAŢIA CALC DIN OPENOFFICE.
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4.8. Diagrame 

4.8.1. Realizarea unei diagrame 

Diagrama este definită ca reprezentarea grafică a datelor de tip numeric dintr-un tabel. 
Pentru  realizarea unei  diagrame se selectează acele  blocuri  de celule  din tabel  care  vor  fi 

reprezentate grafic (inclusiv celulele corespunzătoare din capul de tabel şi eventualele celule cu text 
explicativ), apoi Insert → Chart şi se parcurg cei patru paşi ai casetei de dialog AutoFormat Chart. 

Construirea  unei  diagrame  se  poate  începe  şi  utilizând  butonul  Insert  Chart  din  bara  de 
instrumente Standard, cu selectarea sau nu în prealabil a datelor sursă, şi dând apoi clic într-o celulă 
din foaia de calcul. 

Pasul 1 permite stabilirea următoarelor aspecte: 
-  Caseta  Range  - conţine datele sursă ale diagramei; acestea pot fi verificate sau, dacă este cazul, 
modificate. 

-  Caseta  Chart results in worksheet  - permite stabilirea amplasării diagramei ca obiect într-una din 
foile  de  calcul  ale  documentului  sau  pe  o  foaie  nouă,  ce  se  va  poziţiona  ca  ultima  foaie  a 
documentului. 

- Opţiunile First row as label şi First column as label se bifează dacă în selectarea datelor sursă s-au 
inclus celule cu text explicativ (antetul de rând, respectiv o coloană cu informaţii de tip text), astfel 
încât acestea să fie tratate ca etichete. 

Pasul  2  permite  alegerea  tipului  diagramei,  din  lista  Choose  a  chart  type.  Tot  aici  se  face  o 
previzualizare a diagramei, iar bifarea opţiunii Show text elements in preview conduce la afişarea în 
previzualizare a obiectelor de tip text (legende, titluri, axe, etc.). 

Comutarea între afişarea în diagramă a seriilor pe rânduri sau pe coloane se realizează alegând 
una dintre opţiunile Rows sau Columns în zona Data series in. 
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Pasul 3 permite alegerea subtipului de diagramă din lista Choose a variant, iar din zona Grid lines  
se poate stabili, prin bifare/ debifare, afişarea liniilor de grilă aferente axelor. 

Pasul 4 permite stabilirea următoarelor aspecte: 
- Caseta Chart Title permite adăugarea unui titlu al diagramei. 

- Opţiunea Legend ascunde sau afişează, prin debifare/ bifare, legenda diagramei. 

- Opţiunile din zona Axis titles permit adăugarea de titluri pentru axe. 
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Între  paşii  parcurşi  pentru  configurarea  diagramei,  deplasarea  se  face  cu  butoanele  Next 
(Următorul) şi  Back  (Înapoi), iar, în cadrul oricăruia dintre paşi, dacă se consideră că informaţiile 
furnizate pentru trasare sunt suficiente, se poate alege  Create  (Creare) pentru realizarea efectivă a 
diagramei. Diagrama apare ca obiect în foaia de calcul specificată la primul pas. 

4.8.2. Editarea diagramei 

Diagramele din foaia de calcul pot fi redimensionate, mutate, copiate, şterse. Pentru a efectua 
aceste acţiuni se selectează mai întâi diagrama cu clic pe ea şi apoi se realizează: 

• Redimensionare – prin glisarea de unul din cei opt marcatori de pe marginile diagramei; 

• Mutare/copiere  –  prin  glisarea  de  o  margine  a  diagramei  (mutare)  sau  prin  glisarea  de  o 
margine  a  diagramei  ţinând  tasta  Ctrl  apăsată  (copiere);  sau  utilizând  comenzile  de 
mutare/copiere cunoscute; 

• Ştergere – prin apăsarea tastei Delete. 

Pentru a modifica o diagramă sau diversele ei  componente,  este necesară selectarea diagramei cu 
dublu clic. Meniul Format conţine comenzi ce permit modificarea aspectului diagramei, printre care: 
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Title - formatarea titlurilor pentru diagramă şi pentru axe. 
Legend - formatarea legendei diagramei, a informaţiilor conţinute şi poziţionarea acesteia. 
Axis - formatarea informaţiilor conţinute pe axele diagramei, scalarea, inclusiv afişarea/ renunţarea la 
afişarea lor. 
Grid - formatarea liniilor de grilă ale axelor. 
Chart Wall - formatarea suprafeţei de sub seriile de date. 
Chart Area - formatarea suprafeţei diagramei. 
Chart Type - modificarea tipului şi/ sau a subtipului (variantei) diagramei.
AutoFormat - modificarea aspectelor stabilite în cadrul paşilor 2-4 ai construirii diagramei. 

Meniul  Insert  conţine  comenzi  pentru  a  adăuga  sau  a  modifica  diverse  componente  pe 
diagramă, printre care: 

Title - adăugarea/ modificarea/ eliminarea titlurilor diagramei şi ale axelor.
Legend - afişarea/ renunţarea la afişarea legendei şi poziţionarea ei.
Data  Labels  -  adăugarea/  eliminarea  etichetelor  de  date  pentru  seriile  de  date  reprezentate  pe 
diagramă. 
Axes - afişarea/ eliminarea informaţiilor conţinute pe axe.
Grids - adăugarea/ eliminarea liniilor de grilă pe diagramă.

Observaţie: dacă diagrama a fost selectată cu dublu clic, se pot opera modificări ale diverselor 
componente  şi  din  meniurile  contextuale  ale  acestora  (clic  dreapta),  alegând  comanda  Object 
Properties. În acelaşi scop pot fi utilizate şi instrumentele disponibile în bara de instrumente specifică, 
care apare în fereastra aplicaţiei Calc la selectarea cu dublu clic a diagramei. 

Ce aţi învăţat în acest capitol ? 
• Cum se realizează o diagramă. 

• Cum se modifică o diagramă. 

• Cum se copiază, mută sau şterge o diagramă. 
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4.9. Vizualizarea şi formatarea documentului 

4.9.1. Modurile de vizualizare a documentului 
Schimbarea dimensiunii de vizualizare a documentului se realizează în caseta de dialog Zoom, 

iar acesta poate fi accesată în două variante: 
- Meniul View → comanda Zoom. 

-  Butonul  Zoom din bara de instrumente Standard.

- Dublu clic sau clic dreapta în bara de stare pe rubrica corespunzătoare. 

Pot fi alese diferite procente de vizualizare prestabilite sau una din variantele: 
• Entire Page - afişează conţinutul întregii pagini 

• Page Width - afişează lăţimea completă a paginii, iar marginile de sus şi/sau jos pot să nu fie 
vizibile 

• Optimal - redimensionează afişarea la lăţimea zonei de celule selectate 

• Variable - se poate completa cu un procent de dimensionare a vizualizării 

Vizualizarea documentului înainte de tipărire: 

Modul de vizualizare Page Preview (Previzualizarea paginii) poate fi accesat din File → Page 
Preview sau din butonul  Page Preview din bara de instrumente Standard. În urma executării acestei 
comenzi va apărea fereastra corespunzătoare reprezentată în figură: 
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Semnificaţia butoanelor din bara de instrumente Page Preview este: 

Previous Page - navigare către pagina anterioară a documentului. 
Next Page - navigare către pagina următoare a documentului. 
First Page - navigare către prima pagină a documentului. 
Last Page - navigare către ultima pagină a documentului.

Zoom In - creşterea dimensiunii de vizualizare (procentul este afişat în bara de stare). 
Zoom Out - diminuarea dimensiunii de vizualizare (procentul este afişat în bara de stare). 
Full Screen - afişarea paginii pe întreg ecranul. 
Format Page - deschiderea casetei de dialog pentru formatarea paginii documentului. 
Close Preview  - închiderea modului de vizualizare  Page Preview  şi revenirea în modul de 

vizualizare Normal (echivalent cu utilizarea tastei Esc).
 Modul de vizualizare Page Preview nu permite editarea informaţiilor din document. 

• Vizualizarea întreruperilor de pagină: 

Accesarea acestui mod de vizualizare se face prin cu View → Page Break Preview. 
Acest  mod  de  vizualizare  al  documentului  afişează  delimitarea  şi  modul  de  succedare  al 

paginilor din care este formată foaia de calcul curentă. În privinţa dispunerii în pagină a informaţiilor  
conţinute în foaia de calcul, acest mod de vizualizare permite: 
- Ajustarea întreruperilor de pagină prin glisarea acestora cu mausul. 

- Inserarea de noi întreruperi de pagină la poziţia celulei curente cu comanda Insert → Manual Break  
→  Row  Break  (întrerupere  de  pagină  orizontală  deasupra  celulei  curente)  sau  Column  Break 
(întrerupere de pagină verticală la stânga celulei active). 

– Eliminarea întreruperilor de pagină create manual cu comanda Edit → Delete Manual Break  
→Row  Break  (elimină  întreruperea  de  pagină  de  deasupra  celulei  curente)  sau  Column  Break 
(elimină întreruperea de pagină din stânga celulei curente).

–
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Se  revine  în  modul  de  vizualizare  Normal  de  editare  se  realizează  cu  View  →  Normal. 
Întreruperile  de  pagină  sunt  vizibile  şi  în  modul  Normal  de vizualizare  după revenirea  din  Page 
Preview sau Page Break Preview. Operaţiile de inserare şi ştergere de întreruperi de pagină manuale 
pot fi efectuate şi în modul Normal. 

4.9.2. Opţiuni de vizualizare 

• Deschiderea unui document în mai multe ferestre 

Pentru a putea vizualiza simultan două sau mai multe foi de calcul ale unui document, acesta poate fi 
deschis  în  mai  multe  ferestre  astfel:  din  meniul  Window  se  dă  comanda  New Window.  Aceasta 
conduce la deschiderea documentului şi într-o altă fereastră. Cele două ferestre pot fi aranjate pe ecran 
astfel încât să fie amândouă vizibile, iar în fiecare dintre ele se poate afişa o altă foaie de calcul a 
aceluiaşi document. 

• Îngheţarea în derulare (Freeze) 

Opţiunea de îngheţare (blocare) în  derulare permite ca anumite zone ale  foii  de calcul  să rămână 
vizibile la defilarea prin foaie, de exemplu menţinerea vizibilă pe ecran a unui cap de tabel sau a unei 
coloane cu etichete. Pentru a îngheţa un panou: 
- Un rând şi zona de deasupra sa: se selectează prima celulă de sub rândul ce va fi blocat 

- O coloană şi zona din stânga sa: se selectează prima celula din dreapta coloanei ce va fi blocată 

- Un rând şi o coloană şi zonele de deasupra, respectiv din stânga: se selectează celula de dedesubtul, 
respectiv din dreapta rândului/ coloanei apoi, din meniul Window se dă comanda Freeze. Renunţarea 
la îngheţarea unui panou se face prin debifarea opţiunii Freeze din meniul Window.

• Împărţirea foii de calcul în panouri (Split) 

Pentru a vizualiza concomitent două zone îndepărtate ale unei foi de calcul, aceasta poate fi împărţită 
în panouri ce permit navigarea independentă. Pentru aceasta, se selectează celula ce va marca locul de 
divizare, apoi Window → Split. Foaia de calcul va fi împărţită în 2 sau 4 panouri cu propriile bare de 
defilare (scrollbars), iar, dacă este necesar, barele de demarcaţie pot fi deplasate prin glisare cu mausul 
pentru a schimba locul de divizare. 
Renunţarea la opţiunea Split se face prin debifarea acesteia din meniul Window. 

4.9.3. Formatarea documentului 

Stabilirea  caracteristicilor  de  formatare  ale  tuturor  paginilor  documentului  se  realizează  în 
caseta de dialog Page Style, care se deschide la comanda Format → Page. Caseta de dialog prezintă 
şapte taburi (file), şi anume: 
-  Tabul Organizer al casetei de dialog Page Style permite vizualizarea caracteristicilor de formatare 
ale stilului de pagină curent,  crearea de noi stiluri  sau modificarea unui stil  existent.  Vor putea fi 
schimbate doar numele stilurilor create manual, nu şi a celor predefinite. 
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Operaţiile de creare, modificare, ştergere, aplicare a unui stil de pagină se realizează în caseta 
de dialog Styles and Formatting tabul → Page Styles (din meniul Format). 

-  Crearea unui nou stil de pagină: clic dreapta în caseta cu lista stilurilor existente → New → 
se stabilesc caracteristicile de formatare ale noului stil de pagină 

-  Modificarea unui stil existent: clic dreapta pe numele unui stil existent → Modify  → se 
operează modificările 

-  Aplicarea unui stil existent pe o foaie de calcul a documentul curent: dublu clic pe numele 
stilului de aplicat 

-  Ştergerea unui stil: clic dreapta pe numele stilului → Delete 

• Tabul Page permite stabilirea următoarelor caracteristici: 
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- Format - stabilirea formatului hârtiei (dimensiuni standard) 

- Width şi Height - lăţimea şi înălţimea hârtiei 

-  Orientation  -  Orientarea  paginii,  care  poate  fi  verticală  (Portrait),  sau  orizontală 
(Landscape) 

- Zona Margins - stabilirea marginilor Top (Sus), Bottom (Jos), Left (Stânga), Right (Dreapta) 
ale paginii 

- Page layout  - diverse moduri de preluare a caracteristicilor de formatare specifice tabului 
Page pentru documente cu pagini multiple 

- Format - formatarea numerotării paginilor 

- Table alignment - centrarea orizontală (Horizontal) şi/ sau verticală (Vertical) a conţinutului 
pe pagină 

• Tabul Borders permite crearea chenarelor de pagină, cu opţiunile: 
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• Line arrangement - chenare predefinite (Default) sau particularizate (User-defined) 

• Line - liniatura chenarelor, cu stilul liniei (lista Style) şi culoarea liniei (lista Color) 

• Spacing to contents  -  distanţele dintre liniile chenarului şi conţinutul documentului, iar prin 
bifarea opţiunii  Syncronize  se aplică automat aceeaşi spaţiere pentru toate cele patru casete 
dacă se introduce o valoare în oricare dintre ele 

• Shadow Style  - efect de umbrire a pentru liniile de chenar, cu opţiunile  Position  - un stil de 
umbrire, Distance - grosimea umbrei, Color - culoarea umbrei 

• Tabul Background - stabilirea unui fundal cromatic al paginii, cu variantele:

- O culoare - se alege din lista As opţiunea Color 

- O imagine din fişier - se alege din lista As opţiunea Graphic 

• Taburile Header şi Footer (Antet şi Subsol), al casetei Page Style permit configurarea zonelor 
de antet şi de subsol. Conţinutul celor două taburi este acelaşi, având următoarele opţiuni: 
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- Header on, respectiv Footer on - adaugă antet/subsol stilului paginii curente 

- Same content left/right - acelaşi antet/subsol pe paginile impare şi pare 

- Left şi Right Margin - distanţele dintre zona de antet/subsol şi marginile stânga şi dreapta ale paginii 

-  Spacing  - distanţa dintre limita inferioară a antetului,  respectiv limita superioară a subsolului şi 
limita superioară, respectiv inferioară a zonei destinate textului 

- Height - înălţimea antetului/subsolului 

- AutoFit Hight - potrivire automată a înălţimii antetului/subsolului la conţinut 

- Butonul  More  deschide caseta de dialog  Borders/ Background, de unde se pot stabili chenare şi 
culori de umplere ale zonelor de antet/subsol. 

- Butonul  Edit  deschide caseta de dialog  Header, respectiv  Footer, pentru inserarea informaţiilor în 
respectivele zone.

Caseta de dialog conţine trei secţiuni în care se introduc informaţiile în funcţie de alinierea 
dorită (Left Area, Center Area, Right Area) (zona stângă, zona centrală, zona dreaptă) şi o bară de 
butoane. 

Butoanele au următoarele semnificaţii: 

• Tabul Sheet (Foaie) este prezentat în figura următoare şi permite stabilirea opţiunilor: 
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- Page order (Ordinea pentru numerotarea paginilor), cu variantele Top to botton, then right (De sus 
în jos, apoi dreapta) şi Left to right, then down (De la stânga la dreapta, apoi în jos) 

- First page number – se optează pentru afişarea sau nu a numerotării primei pagini a documentului 
sau a zonei de imprimat şi se stabileşte valoarea de început a numerotării 

- Print (Tipărire) - prin bifare/debifare se poate stabili imprimarea sau nu a următoarelor elemente: 
• Column and row headers  -  antetele  de rând şi  se coloană (literele coloanelor  şi  numerele 

rândurilor) 

o Grid - liniile de grilă ale foii de calcul 

o Notes - notele 

o Objects/ graphics - obiectele inserate şi elemantele grafice 

o Charts - diagramele 

o Drawing objects - obiectele desenate 

o Formulas - formulele conţinute în celule, şi nu rezultatele acestora 

o Zero values - celulele ce conţin valoarea 0 (zero) 
- Scaling mode (Modalitatea de scalare), permite redimensionarea, ajustarea documentului pentru a se 
putea încadra într-un număr de pagini stabilit. 
o  Reduce/ enlarge printout  - specificarea unui factor de scalare pentru toate zonele de imprimat. 
Factorul de scalare se exprimă ca procent în caseta Scaling Factor. 

o Fit print range(s) to width/ height - stabilirea numărului maxim de pagini pe orizontală (Width in  
pages) şi pe verticală (Height in pages) pe care se va tipări fiecare foaie de calcul. Factorul de scalare 
se va ajusta corespunzător; nemodificarea celor două casete conduce la un factor de scalare de 100%. 

o Fit print ranges(s) on number of pages - stabilirea numărului maxim de pagini pe care se va tipări 
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fiecare foaie de calcul. Scalarea se va reduce astfel încât să se realizeze încadrarea foii în numărul de 
pagini indicat. 

Ce aţi învăţat în acest capitol ? 

• Cum se utilizează diversele moduri de vizualizare. 

• Cum se formatează paginile unei foi de calcul sau ale întregului document .
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4.10. Tipărirea 

4.10.1. Stabilirea zonei de imprimare 

Stabilirea zonelor pentru imprimare (Print Ranges) presupune indicarea celulelor care vor fi 
imprimate. Nedefinirea manuală unor astfel de zone face ca aplicaţia Calc să stabilească automat zona 
de imprimat astfel încât aceasta să conţină toate celulele cu conţinut (care nu sunt goale) din 
document. Se definesc, extind, elimină, modifică zonele de imprimat: 
- Definirea celulei active sau a unei selecţii ca zonă de imprimat: Format → Print Ranges → Define. 

- Adăugarea selecţiei curente la zonele deja definite: Format → Print Ranges → Add. 

- Eliminarea zonelor de imprimare definite anterior: Format → Print Ranges → Remove. 

-  Specificarea şi modificarea zonelor de editare:  Format  →  Print Ranges  →Edit  →  rubrica  Print  
Rage din caseta de dialog Edit Print Ranges 

-  Pentru  a  stabili  imprimarea  la  începutul  fiecărei  pagini  tipărite  a  unuia  sau mai  multor  rânduri 
(opţiune utilă pentru tabelele cu număr mare de linii), acestea se specifică la rubrica Rows to repeat a 
casetei de dialog Edit Print Ranges 

- Pentru a stabili imprimarea în partea stângă a fiecărei pagini tipărite a uneia sau mai multor coloane 
(opţiune utilă pentru tabelele cu număr mare de coloane), acestea se specifică la rubrica Columns to 
repeat a casetei de dialog Edit Print Ranges 

4.10.2. Stabilirea opţiunilor de tipărire 

Operaţia de tipărire se realizează din meniul File → Print: 

Caseta de dialog Print permite stabilirea următoarelor aspecte: 

- Printer name (Nume Imprimantă) → selectarea unei alte imprimante în afară de cea implicită. 

- Print Range (Zona de imprimat) → tipărirea zonelor de imprimat definite anterior sau, în cazul în 
care nu s-au definit, a întregului document (All), a unor anumite pagini, specificate în caseta  Pages, 
sau doar a unei zone selectate anterior, dacă se bifează opţiunea Selection. 

- Number of Copies (Număr de copii) → numărul de exemplare de tipărit. 
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Opţiunile de tipărire se stabilesc din caseta de dialog  Printer Options, care se deschide cu butonul 
Options, şi acestea sunt: 

- Print only selected sheets → imprima doar conţinutul foilor de calcul selectate 

- Suppress output of empty pages → omite de la imprimare paginile fără conţinut 

Ce aţi învăţat în acest capitol ? 
• Cum se stabileşte zona pentru imprimare. 

• Cum se realizează tipărirea întregului document sau a unei zone a acestuia. 

• Care sunt şi cum se stabilesc opţiunile de tipărire. 
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